A JavaScript error occurred in the main process

Navigraph desktop Chart constantly throwing this error:
[Window Title]

[Main Instruction]
A JavaScript error occurred in the main process

Uncaught Exception:
Error: Command failed: powershell.exe -NoProfile -NonInteractive -InputFormat None -Command Get-AuthenticodeSignature -LiteralPath ‘C:\Users\payth\AppData\Local\navigraph-charts-updater\pending\temp-Navigraph Charts 8.13.1.exe’ | ConvertTo-Json -Compress | ForEach-Object { [Convert]::ToBase64String([System.Text.Encoding]::UTF8.GetBytes($_)) }
Get-AuthenticodeSignature : File C:\Users\payth\AppData\Local\navigraph-charts-updater\pending\temp-Navigraph Charts
8.13.1.exe was not found.
At line:1 char:1

  • Get-AuthenticodeSignature -LiteralPath 'C:\Users\payth\AppData\Local\ …
  •   + CategoryInfo          : ObjectNotFound: (:) [Get-AuthenticodeSignature], FileNotFoundException
      + FullyQualifiedErrorId : SignatureCommandsBaseFileNotFound,Microsoft.PowerShell.Commands.GetAuthenticodeSignature 
      at ChildProcess.exithandler (node:child_process:407:12)
      at ChildProcess.emit (node:events:527:28)
      at maybeClose (node:internal/child_process:1092:16)
      at ChildProcess._handle.onexit (node:internal/child_process:302:5)


I’m receiving the same error, every couple of minutes

Same here. Navigraph charts is installed on a old PC I don’t use for flightsimming, but the previous version worked flawlessly with no errors.

Same error here… I’m receiving the same error, every couple of minutes

I uninstalled and reinstalled Navigraph Charts which appears to have resolved the constant javascript bug which was due to the app not finding an exe for some reason. What’s weird is Navigraph Chart worked fine yesterday, but not today.

Uninstalling and reinstalling seems to have worked for me as well.

Same error here but uninstalling and reinstalling has not fixed it. Same on 2 pcs. Pretty sure it was OK yesterday.

Same issue here. Seems to be a problem update file (v 8.3.1) in the update pending folder (\AppData\Local\navigraph-charts-updater\pending) which Windows reports as corrupt and won’t execute.

Hopefully that update was to fix the constant login problem and they’ll release something to fix both soon!


You can get the latest app manually by downloading the installer from Navigraph. Does that work better?

Yes, 8.13.1 resolves the sign out issue.



1 Like

That seems to have fixed it - thanks very much. As an aside, would it be possible to put a version number on the download page so we know which one is current for each platform? Cheers!

I’m getting the java script error, and when I look in processes, I have some part of the app still running. Once I clear that manually, each time, I can run the app again. I’ve reinstalled twice and get the same error.

It seem to be related to the update of the application.
Now i have updated to version 8.14.0 and i hope that the problem is fixed :slight_smile:


Yes, 8.14 resolves the Javascript error, which is sometimes popping up in the auto-update process in the 8.13 versions. After you get 8.14 you should not see it any longer.



1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.