"simbrief downloader" it gets stuck

Hi guys.
When I open “simbrief downloader” it gets stuck (message “loading”), I have windows 10.
Can you help me to solve the problem? (upload image)

Thank you.



Use Windows to uninstall Simbrief Downloader. Redownload and install latest SimBrief Downloader.

Please let us know how you get on.


Thank you very much for answering. I have already tried as you suggest on several occasions but the error persists.

Hi, where have you installed the Downloader program? Can you provide the full path, and maybe a screenshot of what that folder looks like?

You can find the install directory by right clicking the SimBrief Downloader shortcut, choosing “Properties”, then in the Shortcut tab, click “Open file location”.

For example, mine is installed in C:\Users\username\AppData\Local\Programs\SimBrief Downloader. And the folder looks like this:

Also, can you also type the following into a File Explorer window address bar and send a screenshot of what this folder looks like as well: %appdata%/SimBrief Downloader.


The path is:
“C:\Program Files\SimBrief Downloader\SimBrief Downloader.exe”

Thank you.

Is there no one who can help me?

Hi, sorry for the delay.

Using your screenshot as a reference, please click in the pink square I’ve drawn:

Type C:\Program Files\SimBrief Downloader\, hit Enter, and take a screenshot of that folder.

Then, in the same box, type %appdata%/SimBrief Downloader, hit Enter, and take a screenshot of that folder as well please.

Best regards,

Uploading: Disco local (C_) 20_05_2022 19_59_21.png…
Disco local (C_) 20_05_2022 19_59_21

Hi, please try to uninstall the SimBrief Downloader.

Then, reinstall it, and you should see this window at some point:


Try to select “Only for me” and see if that works better.

If not, uninstall and reinstall again, this time clicking “Anyone who uses this computer” instead.

When installing, it’s also a good idea to right-click the installer and choose “Run as administrator”.

Best regards,

It is impossible. Neither of those options works.

Same here, did anything as required and than always this with version undefined in the down part…

Has this been resolved? I have tried multiple times to uninstall and reinstall this via the instructions above but it still comes up “version undefined”

Found it! I don’t use OneDrive so I deleted my \Users\jgniew\OneDrive\Documents folder. Added it back in and all is well!

Interesting that it needed the OneDrive folder to work.

This might help other users in the future, thanks!

I have the same problem after a recovery from Acronis. After a new installation with administrator rights, only the opening window remains. I’ve tried installing both a new and an older version, but it won’t start. The one drive folder is present. Can someone help me?