[P3D v5.3] Simlink causes CTD no error

Edit: I have managed to resolve the duplicate v4 plugin problem, there was an extra registry entry I wasn’t aware of that I’ve now deleted. However I am still getting the errors when I load into 5.3

Hi,
I’ve recently been experiencing some odd behavour with Simlink, which I have also now correlated with some CTD issues I have recently been having in P3D.

Regarding the CTDs. I have been finding that long(er) flights and sessions of a few hours or more have a tendency to result in freezes or (more commonly) CTDs without anything showing in Event viewer.
Most recently I flew PANC-KLAX in the PMDG 747-400, this was the second long haul trip I made in v5.3 with the first being VHHX-PANC, and the first after configuring Simlink for the new 5.3 install. I got a CTD after lining up for approach, with no suggestion as to the issue. There was nothing in event viewer to suggest what went wrong. I repeated the exact same flight the next day except with Simlink disabled and the flight succeeded with no CTD.

After some troubleshooting I then noticed that Navigraph simlink was producing logs all with the same error:

[2021-12-08 03:07:29] Status: 0; Last error: 183

This error repeats multiple times, and I have a feeling it is responsible for P3D Crashing, as I believe the same error has been known to crash XP11 for some users.

I have uninstalled, reinstalled and reconfigured Simlink and the charts app, however this has not stopped the errors. Interestingly when I ask it to scan for my P3D install it insists on installing the plugin for v4 as well as v5. I previously had v4 installed on this machine but I have made the utmost effort to scrub it from my machine, all the main directories are deleted and there are no remaining registry entries to my knowledge, but Simlink keeps on picking it up.
I have also deleted the ‘P3D v4 Addons’ and verified there are no shortcuts, however this does not appear to have fixed the issue.

Any idea what the issue may be? Any help appreciated.

Kind Regards,
Martin

I have been experiencing sudden P3DV5.1 CTDs for the past week, after many months of completely stable operation. My Prepar3Dv5xxxxxxx log files have the same error repeated many times.

There could of course be other explanations, but it would be nice to know the meaning of the log entry shown above.

Hello,

i have the same Error and CTD´s with SimLink in my X Plane and i hope the will be a Fix soon.

Hi,
Shortly after I posted this I was contacted by Vishal who did some troubleshooting, I haven’t gotten round to following up as I have not been spending much time on the sim owing to partaking in seasonal festivities.

I intend to continue chasing this issue in the new year, I just ran a flight today which ended in a no-error CTD approximately 9 hours into the flight. When able I’ll repeat the same flight and try to narrow down what’s happening more throughtly. It’s a possibility that Simlink isn’t causing the issue but so far it has been the most consistent correlating factor.

I’ll do my best to report back

Kind Regards,
Martin

1 Like