Navigraph not updating MSFS 2020 database

Hello,

I’ve been having some problems with navigraph and MSFS 2020, as I can update the AIRAC via Navigraph.exe, but the sim database doesn’t get updated.
I’ve tried to remove and install the airac; also updated the navigraph beta app.

If you guys could help me…

Thanks in advance,

Andre Simoes

Hi Andre,

Welcome.

What makes you think the Beta Navdata update hasn’t occurred.

Do you have the following in Content Manager?

Cheers
Ian

Thanks for the response.
I have this installed and it seems correct.
However, the database in the sim is not the same as the one in Charts app.
So, I uninstalled navigraph airac and confirmed the same differences.
I think that, although the sim shows me the correct airac, somehow it is not using navigaph database, but its own.

Hope that helps clarify my problem.

Andre

1 Like

A post was split to a new topic: TXKF STAR not the same as per LNM

Hi Andre,

Please post screenshots using Guide to posting Screenshots showing specifics of what you mean.

Cheers
Ian

Hi, Ian

Hope I can explain it well enough:

In Charts, I can see the correct airport ICAO (comparing it to brazilian aeronautical departament):

MARICA airport designation is correct: SBMI.

I have installed the updated database, as you can see below:

MSFS confirms the correct airac is installed:

However, if I try to plan the same flight to SBMI (which was supposed to be MACAE), MSFS considers a totally different airport (ERMIDINHA), almost 400nm away:

See that I’m using the exact same destination: SBMI. However, MSFS map shows me a different airport.

I tried to uninstall Navigraph AIRAC and MSFS showed the exact same destination (ERMIDINHA, opposed to the correct MARICA). So, I figured (maybe I’m wrong about this one) that, despite the AIRAC, MSFS is using its own database, and not Navigraph’s.

Thank you very much for your help. Hope my problem gets a fix.

Andre Simoes

Hi Andre,
not Ian, but I can also answer this question:

The problem here is the wrong airport position in MSFS for SBMI.

In the sim you have:
Latitude: -16.433723449707
Longitude: -44.0570983886719

In real, and in our database you have, the airport reference point is:
Latitude: -22.91805556
Longitude: -42.82888889

You see, the sim point is far away from the original, real-world point.

So, why is the airport than not on the correct place with the AIRAC update, when our data are correct (as you also have figured out in the charts)? The answer is simple: we may not move existing airports in MSFS, so we must use exactly these wrong coordinates from the MSFS. Normally there are existing an “Airport Reference Point”, which is a standardized, special point on every airport. You see this point on every airport-diagram called ARP - here an example from SBGL:

But ASOBO doesn´t use this point, they take an own point somewhere on the airport. And therefore, we can use our database ARP, we must use their “ARP” point and this point is simple wrong and therefore you get a wrong result.

It´s not a database issue, we have the correct coordinates but due the internal logic of the MSFS we can´t use this ARP - we must use the MSFS ARP, which is in most cases not the same as the real-world ARP. In this case, it´s completely wrong.

So, what you can do is, that you report this to ASOBO, that they fix this … sorry.
Cheers,
Richard

PS: you haven´t done anything wrong in the installation - what I see, the data are correct installed - so it´s no issue on your end - it´s a bug in the MSFS

2 Likes

Richard,

Thank you for your time.
It’s a pity that the solution is harder than I had thought. I imagine ASOBO won’t fix the coordinates to an unknown airport.
At least I figured out one thing: Navigraph support rocks!

Cheers,

Andre

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.