Navigraph Hub Zlib could not depress the stream, Header Length

Hi, I’m trying to update my current AIRAC and PMDG however I keep receiving this message. i have tried to uninstall everything, however this didn’t work. i have also tried to change permissions in certain apps, however this doesn’t work either, and I’m getting quite frustrated how to try and solve this issue. i have tried to google this however nothing seems to come up to assist me. I’m hoping someone has any ideas how to fix this issue.

Hello and welcome to the forum!

Sorry to see that you are having issues with the hub. Based on that error message, it looks like something external (not the hub) is interfering with your internet connection, which in this case is causing the hub to receive incomplete and/or corrupt data when trying to download the navdata.

Unfortunately we cannot do anything about this, but perhaps we can help in some way by providing you with a few things to check:

  • Do you have any 3rd party software installed that might monitor or alter your network traffic? Antivirus, firewall, reverse proxies, VPNs etc.
  • What kind of network are you on? Wired fibre, ADSL, mobile tethering etc. - your ISP might be having some issues, or perhaps they have policies in place that prevent downloading in chunks. Try a different connection and see if the issue persists!

I’m sorry for not being able to directly find you a solution, but based on what you have sent so far the issue is not in our application but rather somewhere upstream.

Kind Regards,

You’re not alone. I have same error.

I just found this post.

I use a sim card to connect to a 4G/5G home router with an ethernet cable out to my computer. The main point is my connection in only via sim card. I am starting to think this is a pattern.

I had this post last month, Navdata Center eventually updated without explanantion.

This appears to be an issue with users getting connected throutgh a sim card. Is there any provision that will allow users to manually update monthly updates? Any help would be greatly appreciated.

Thank you,

That makes sense - see this point in my post above:

Some mobile network operators do not provide the ability to download files in chunks, which is normal and something that we do in the Hub. That would probably be the answer to why it fails for you!

Unfortunately, there is no other way to download the data at the moment. We do have manual installers available for download from our website, but none for MSFS for technical reasons.

We’ll investigate possible workarounds for this. In the meantime, using another internet connection from an ISP that does not have this limitation would work fine!

Kind Regards,

I started having this issue when they have changed to Navigraph Hub… one minute, it works fine… next minute… it doesnt. Once you click on INSTALL on AIRAC and even install for PMDG product, you loose all navigation information in the sim. Sim is now unusable…

Not an issue with different internet connection as I used 3 other connections… no VPN or antivirus. Why would it work fine last time I updated and this time it doesn’t…

But yea, my sim is unusable now. I reported this issue back in May so it seems like its still not fixed… after a while, it started working… now the problem has returned.


Welcome. I don’t see any prior post from you in the forum.

Although not generally recommended, try quitting the Hub, and using right mouse run as administrator on the Navigraph Hub. Any improvement?


Hi Ian,

Its the first time I have posted it on the forum. First time was via twitter.

I have done the following

  • Run as Admin
  • Reinstalled
  • Changed my internet connection

Still no luck

I appreciate your response. It appears I am currently stuck on the last Navigraph update. This started happening last month and has been good for the year prior with the same connection I have now. Was there an update that is preventing it from working now? I do not have another way to connect as the 4G/5G modem (Huawei 5G CPE Pro) is all that is available to me. I look forward to a workaround.

Ok I think I have found a solution for this…

Head over to this location in your explorer
C:\Users\USERNAME\AppData\Local\Temp\Navigraph and I removed everything in that folder. It started working.

That’s terrific to hear! Let’s hope that others in this thread can confirm this to be a solution.

The team is currently preoccupied with preparations for FSExpo, but if this is still an issue after the event we’ll make sure to look into it!

Have a great weekend!
Kind Regards,

No luck here but thanks for posting for others to see.

What if you manually extract the stuff to your sim

So I started to play with a manual extract as you suggested. I did not jave a 7zip extracter installed so I downloaded BreeZip from the MS Store. I opened Navigraph Hub to download the .7z archive that Navigraph Hub drops into the temp folder.

To my surprise the AIRAC cycles for MSFS and two PMDG aircraft downloaded and installed without any workarounds. I am not sure why or how but the only difference is the BreeZip program installation. If I was brave I would remove them and see if its repeatable. I think I’ll just wait until next months update. Anyway, thanks for the suggestion as that prompted me to play with it. I think I’ll go enjoy a flight now.

tried VPN, it helped me

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

If anyone still have the zlib decompression problem, please try this version which gives us better logging for the error.

Kind regards,