Zlib header length


I just cannot manage to update after any airac cycle. I simply get the Zlib header length error message.

I have uninstalled and reinstalled the latest hub several times.

I have deleted the folder and files in the localtemp folder.

I have checked all the permissions on all folders.

I just cannot install to either the Fenix or main tab.

I have also used 2 different WIFI connections and a 3rd 5g connection from my phone.

Please can you help as I’ve reached the end of the line trying to fix it myself.

This has been going on for the last 3-4 airac cycles.
I’m using W10.

Cheers, Mike

Hi @gkclubber

Can you please try this version:

You will most probably still get an error message, but it might more accurately describe what is going on so that we can investigate.

Kind regards,


Hi Markus

Thanks for the reply.

On trying with your version of 1.2.8 i get a stream download error for both the main base package and Fenix install.

I have tried running the hub in and out of admin mode.

Cheers, Mike

Hi again,

The “aborted” message hints at this being some kind of network error. We mainly see this happen on mobile networks although I am not able to reproduce it myself with my mobile provider. I also see that you have used two different WIFI routers, and I assume these are not connected to cellular networks?
Do you have the possibility to try again using a VPN?

Kind regards,


Hi again.

I don’t have a VPN, so unfortunately can’t try that.

I have tried with 1) a WIFI router connected to a normal cable phone line. 2) a WIFI router connected to a cellular 4G network. 3) hotspot connection to a different 5G cellular network.

All of them gave me the Zlib header error for the last 3-4 airac cycles.

The only other thing to mention is that I did have the beta software for the navigraph ingame panel before it was released. Not sure of that makes any difference.

Thanks again, Mike

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.