G5000 in Citation Longitude does everything BUT allow for FP selection

I found a user with a similar problem but he was a beta tester and by signing in and out of his FMS, his problem was solved (ERROR Loading flight plan SimBrief - #2 by stephen)

I can see on the flight computer that I’m linked to Simbrief – it shows my user name and ‘Unlimited’ subscription. I have never been able to pull up a SB flight plan using the Simbrief button.

Yes, I have the G5000 v1.2.5 plugin installed. Yes I have signed out and back into the flight computer. Yes I have reinstalled the plugin. But when in cockpit, I see a completely blank space where my light plan should be.

Lastly, if I switch over to the Citation CJ4, it’s FMS flawlessly pulls in SB data via ‘Route Recall’ for the any/all of the flight plans that it’s bigger cousin doesn’t see or won’t show me.



From the cockpit, I can

What I expected to happen.

Clarify your expectations. It’s easier to understand the anticipated
behavior and determine whether it’s truly a bug or a usability issue that
needs to be reviewed.

What actually happened

Please describe what happened in a way that enables us to find the problem
without follow-up questions. For instance, saying “the charts do not work”
or “login is broken” doesn’t help. To the extent that it is possible, please provide clear steps to reproduce the
problem. Screenshots and error messages are helpful and encouraged!

Hello! Welcome to our forum!

First, let’s make sure that I understand you correctly!

Do you mean this list?

And if so, I assume that:

  • You have recently dispatched a flight in SimBrief
  • Nothing shows up when refreshing

Is all this correct?

Kind Regards,

Thanks for the welcome and thanks so much for getting in touch!

In short: everything you have asked is ‘all correct’.

Additionally, the SimBrief Panel (from the Toolbar) is ~100% reliable when I tap “Fetch”, by contrast (screenshot attached) – but of course that doesn’t make it to the G5000 in any form.

That’s puzzling, I am not able to reproduce this issue.

Unfortunately, debugging this is not that easy so bear with me! Please follow these steps:

  1. Start a new flight in the Longitude
  2. Open http://localhost:19999
  3. In the list of links that appears, find the entry that includes GTC_2 and click on it
  4. Wait for the interface to load completely
  5. Along the top edge, find the tab named “Console” and click on it
  6. Scroll to the bottom
  7. In the Longitude, locate the captain side center GTC and open the SimBrief page
  8. Press refresh - Does anything show up in the log? (from step #5)

Let me know if you have trouble with any of the steps. As a backup plan, I could connect to your PC remotely and take a look!

Kind Regards,

I was able to follow your instructions.
I see a number of “failed to load resource” messages that were present BEFORE attempting to load from CPT side center GTC → SimBrief.
*No new entries showed up in the Console after I pressed “Refresh List” on the GTC.

Here are the screen shots. I am agreeable to remote access if that will help.

That’s great! The “failed to load resource” messages are normal for the simulator.

Here are some additional ones to help narrow this down even further! The steps assume that you have completed steps 0 to 2 from the previous steps.

  1. Locate the “Resources” tab along the top and click on it
  2. To the left there should be a list of folders. Locate the one labeled XHRs and expand it
  3. Click on the flightplans item. If there is no such entry, press the Refresh List button in the GTC
  4. Press the “Show details” button in the top right (see screenshot for reference)
  5. Take a screenshot of the full result and send it in your next post

Kind Regards,

Also, regarding this statement:

Could you send me a screenshot of this page (Navigraph Settings) in the GTC? You are likely not signed into the correct account, but this can be confirmed with a screenshot.

Kind Regards,

In reverse order: here’s the Navigraph Settings and my Resources with XHRs on the Sidebar appearing not to have any contents/subfolders.

Screenshot 2024-03-27 065904

And yes, I did go back and attempt to Refresh List on the CPT side GTC but nothing changed in the Resources in terms of populating XHRs.

Also, for what it’s worth, I checked the SimBrief Panel from the MSFS Toolbar – I looked at its user name – and it is the same as what I’m posting as here and what is in the screenshot showing Unlimited Navigraph. Let me know if having a screenshot of the OFP that I fetched via that panel for my pending flight is of any use. Please and thank you.

Hmm, that’s unfortunate. The interface looks buggy, probably due to using the web browser instead of the debugger included in the SDK.

I am not sure what the SimBrief panel does since it is not developed by us, but I am fairly sure that it uses outdated APIs. This would mean that the username cannot be used as a reference there, since the old APIs worked differently.

From our point of view, it looks like you have two Navigraph accounts with the following (masked) email addresses:

  • nonious@*****.com
  • web@*************.com

The plugin (and your profile on this forum) seems to be using the second one. This account has never been used to sign in to SimBrief, so therein probably lies your issue. You can confirm this by following these steps:

  1. Sign out of SimBrief
  2. Press the “Sign In” button
  3. Make sure to sign in with the email beginning with web.

Note: It looks like you also have two subscriptions with us, one for each account. I would recommend that you pick one of them and stick to it, canceling your subscription for the other.

Kind Regards,

When I upgraded to Premium sometime in the last 2 weeks, it was with the web@ address. It prompted me to import from (the old system?) where user name was not necessarily an email address. I did import and it worked great.

Now, following your instructions, signing back in to SimBrief as web@ it’s prompting me to import, but giving a warning to contact support. Can you clear this block?? (the red text in the screenshot)

P.S. I don’t know if you worked on/support the CJ4, but its FMC uses SimBrief numeric pilot ID to fetch flight plan. It has worked flawlessly since I first “got back into” switching from XPlane to MSFS 2020. Been so much harder on the Longitude.

Also, I know it’s not your development - and I’m not trying to contradict you - but the SimBrief Panel works with user name. Here’s the main page and the settings page for the flight I’m waiting to make:

Also, when I was installing Navigraph Charts and Hub after getting Premium, I do recall that I had to make 2 payments through PayPal because after the first one, I could not get everything in sync. I did monthly on the nonious@ and the web@ but have since upgraded the web@ to switch to Yearly at the end of the month cycle.

Can you have the other one canceled/refunded? (I never used it – I thought it would sort itself out – they were purchased within minutes of each other because Navigraph Charts was saying I didn’t have Premium access even though I just purchased it).

We’re looking closer at the situation, I will let you know when I know more about the red block and its originating issue. In the meantime, here are answers to the other questions:

We did not work on that integration, no. What you are describing is the legacy/outdated API which is no longer in use by us, but we keep maintaining it to support these MSFS integrations specifically!

Apologies for the inconvenience! I am not sure how you ended up in this scenario yet, but the process is supposed to be even easier than the pilot ID version since you do not need to worry about anything other than signing in with your Navigraph account, which should be a 10-second process.

I have downloaded the panel and checked the code - it is indeed using the outdated APIs. You can use either the Pilot ID or the username, this toolbar uses the latter, which ends up fetching flightplans from your account with the nonious@** email.

Yes, that is fully expected. Both accounts have access to charts! The issue with SimBrief is that you are creating flightplans with one account, and then trying to load those flightplans from a different account.

Please confirm: You want me to cancel and refund the subscription for the nonious@** account?

Alright, we have the situation figured out. Just let us know which account you would like to keep and we’ll handle the rest!

Confirmed on cancel/refund the single month for nonious@

P.S. I know y’all are looking at things more closely, but to be clear, I am definitely the user that already imported the nonious (alias, not email) on that screen with the red error.

I first started using SimBrief around 2008 or so but have been away for 6 or more years until the last few weeks). I thought everything went smoothly in transitioning to the master account web@ and that I was signing into SimBrief with web@ since my return because I could not proceed, even with the free offering, to login with the alias in the present-day (upgraded) login/authentication system. If any of that helps. Thanks for your help. Standing by on the ground somewhere in western Brazil, connected to external power :slight_smile:

1 Like

Keep web@ please and thank you, sir.

Thanks for the confirmation!

We have moved all your SimBrief data from nonious@**.com to web@**.com. We’ve also canceled your subscription for the account associated with nonious@**.com and issued a full refund!

I would suggest that you remove the account associated with nonious@**.com. You can do this through your account page when signed in, or I can do it for you. Please let me know which option you’d prefer!

All that is left after this is to sign out everywhere and make sure to sign in with the correct account!