Can't Login From Within X-Plane and Avitab

I am not able to connect with my account from within X-Plane 11 using Avitab.

Everything was working until I tried today and then I had to login again for some reason. When I try to login at your site when the browser takes me to you and after I enter my emai and password, I get the following error:

“AviTab Error: Invalid RS256 signature”

Can you tell me what the issue is and why I can’t connect to my account?

Thank you


same!!! needs to be fixed asap

1 Like

Thanks for confirming that I’m not the only person having this same problem.
You always wonder if it’s just me or are others experiencing the same issue!

I thought it was just me. Same issue here. I tried redownloading latest AviTab version as well but no luck…


I am getting the same error.

me too… I thought it was only me since RS are my initials hahaha … hopefully it will be solved quickly…


Hello everyone!

Thanks for letting us know, we are looking into this!

Kind Regards,

Hello again!

Quick update: This is an issue in the Avitab code, and we’ll reach out to Folke (the developer behind Avitab) to make him aware of it. We’re sorry about the inconvenience in the meantime!

The reason this came up is that we have taken some steps to improve the security of our systems, and Avitab is using some hardcoded values that cannot adapt to our changes. We’ll help out to the best of our abilities to solve this as soon as possible!

Thank you for your patience.

Kind Regards,

Another update:

We have temporarily rolled back our changes while we wait for a response. Avitab should now be working again! Let me know if that is not the case.

Still not working :frowning: .

Sorry, I was too eager to let you know. The change is still rolling out, and should be generally available within 15 minutes! Apologies for the mistake.

Thanks for your efforts& help.
Ok, standby

Works fine. Confirmed.

The change is now fully rolled back. We will make sure that Avitab has been updated before rolling them out again!


Everything is working now.

Thank you for looking into this and getting it resolved as quickly as you did! :+1:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.