Airport and other charts not showing

New ultimate subscriber here!

I’m not getting airport/SID/STAR charts to show on the map. It’s just blank when clicking “Show charts list”. Is there something I need to activate to get this working?

image

1 Like

I am having the same issue. I think it is on Navigraph’s end.

1 Like

Ok, so perhaps I started my subscription at a bad time. :slight_smile:

I’m having the same issue this morning.

I have the same issue at this moment.

Can confirm I currently have the same issue, using PC and mobile browser

Same here …no Clouds…Lets get on it people!!!

The desktop app is working, just tested.

I have now reestablished charts on my PC. My Mac, however, displays the maps but not the charts. Please advise.

No charts, check to see if your charts are working

Nope, not working for me. Logged in to charts.navigraph.com on Google Chrome.

We’re checking. Please standby.

2 Likes

Standing by, fingers crossed

Same for me no charts

I have this problem, some solution or something

We’re still working on a fix. Please hold out a little while longer.

I also have no charts on my PC ((
The problem was discovered 5 hours ago and still hasn’t been fixed!
Technical support, where are you?

I wrote the last update 23 minutes ago. We’re here. The issue is trickier to resolve than anticipated but we have a fix in testing now. The iPad/Android and Desktop apps should not be affected however.

1 Like

thank you very much for your reply.
good luck

still broken for me :slight_smile: