Update of CRJ 550/700 data freezes Navdata Centre

Hi - I have the CRJ 550/700 (not the 900/1000) bought from Aerosoft and MSFS bought from the MSStore. The CRJ is installed in the Community folder.
I have never been able to update the NavData from the Navdata Centre. When I click update, Centre freezes and I have to quit from the system tray icon.
I have the latest Centre and CRJ.
I did look through the forum but cant find anything specific for my problem other than to update to the latest versions.
Unfortunately this hasn’t helped.
Thx in advance

Hi Ray,
try to disable all anti-virus or firewall settings on your side (at least for this app). It looks, that something blocks the copy process or at least make it very, very slow.

The sim is closed when you update the data, correct?

What you can also try is, reboot your machine and start the update before you do anything first … possible some addon/app and/or the sim blocks something and that´s a good test.


Thx for the reply Richard,
As suggested I disabled anti-virus, made sure the Navdata app had access in firewall (both private and public) and rebooted to make sure nothing was running.
Unfortunately this did not help.
The app was consuming CPU cycles (~12%) as I did turn on Task Mgr to check. After nearly 20 minutes I aborted the app.
I will try reinstalling both the CRJ and the Navdata app to just ensure I have clean installs.
I’m not comfortable reinstalling MSFS.
I’ll advise when I have tried again.
Thx again.

Hi Richard,
Letting you know that I uninstalled the CRJ, uninstalled the Navigraph Airac cycle then uninstalled Navdata Central.
Reinstalled the CRJ and ran MSFS to run first install etc. All OK and shutdown MSFS.
Reinstalled Navdata Central and updated to the latest Airac cycle.
Disabled my antivirus (Microsoft).
Hit Update CRJ in Navdata Central.
Unfortunately no change - consuming ~12% CPU cycles for about 20 minutes the I aborted the process.
I’m wondering if there is a manual way I can update the cycle for the CRJ until this is resolved?
Once again thx for your assistance.

Hi agian Ray,
strange, very strange but it looks really more an issue on your end because there are currently no report like this. Not here in the forum, nor in our ticket-system, but anyway … you can download the manual-installer and can try it with a standalone setup.

You will find the setup here (Aerosoft CRJ Professional):

After starting you can select “Microsoft Flight Simulator” and the all should be done automatically than … I´m curious if this works because the method is equal the same as in the Navigraph Navdata Center. But I cross the finger … :wink:


Hi Richard,
On trying to run the manual install, this was the problem:

Simply running the program as Administrator fixed the problem.
On starting Navdata Central I was easily able to remove and reinstall if I ran Central as Administrator.
Its always the simple things :joy:
Thx for the help.
A couple of things I noticed:
On downloading the latest NavData Central from the site I received v1.06 not 1.07.
I installed for myself (checkbox). Not sure if this is the reason I didn’t get appropriate privilege’s.
cheers and thx again,

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.