Problems signing into Simlink

Hi

Since I downloaded and installed the latest version of Mac OS Sonoma 14.0, I have been having problems with Simlink. Either not automatically signing in when X plane 12 is launched, not being able to sign in at all, or constant crashes.

I have uninstalled Simlink and reinstalled several times to no avail.

Please advise.

Regards

Iain Cooper

Hi,

It looks like the Simlink configuration is not correct, Please follow these steps to correct the Simlink configuration.

Kind Regards,

Vishal Ahir
Navigraph

OS 10.13.6 user – updated Simlink now will not load. “quit unexpectedly” splash screen.
Followed your 4-step process but no Navigraph files found in ~/Library/Application Support/

Hi,

As per your details, it was look like you are using old version of macOS,
Please use this version for your macOS version.

Please let me know if you face issues with this version.

Kind Regards,

Vishal Ahir
Navigraph

Thenks.
If I upgrade I can’t run my NVIDA card. So, I guess It’s goodby and hello ForeFlight.

HI,

No need to upgrade macOS just install the Simlink-compatible version which I mentioned above.

Kind Regards,

Vishal Ahir
Navigraph

So sorry. My morning coffee had not kicked in.
Thanks for the solution.

Next question: What version of Nav Charts works with this version of Simlink? I have Nav Charts 8.31.0

HI,

This version is also compatible with the Navigraph Charts.

Kind Regards,

Vishal Ahir
Navigraph

Still having issues. When I start SimLink:

  1. it prompts me to update which I decline.
  2. It opens my browser to sign in to Navegraph
  3. It quickly then displays splash screen saying SimLink quit unexpectedly
  4. I log in via the browser prompts
  5. Prompted to open SimLink app which I do
  6. Navigraph SimLink splash screen asks me to sign in. Clicking yes sends me back to the browser sign in (see #2) and I’m back in a loop.

Please advise. Thanks

I think I have found the sequence that works.

  1. log in to navgraph via browser
  2. start SimLink
  3. start Charts