Login Issues on FMS Data Manager


Im trying to log into FMS Data Manager and get an invalid email/password error, (I am able to login to website… fine just have the problem with FMS Data Manager)

I have checked that the login details are correct and have also tried resetting the password to a simplier version without special characters incase that is the issue.

The exact message I get is “Your email or password is incorrect” which is at the top of the screen just under the Navigraph logo.

Can anyone help?



Check you are entering email, and not username.

Also please see FAQ - No subscription indicated , when you have a valid subscription


If no joy,

I suggest a fresh start using exact procedure below:

Please disable any Antivirus and firewall. Uninstall AV if needed.

Use Windows to uninstall FMS Data Manager. Specifically:

  1. Press Start and open Apps & Features.
  2. On the right hand side, open Programs and Features.
  3. Find Navigraph FMS Data Manager in the list, select it, and press the Uninstall button above.

If they exist, delete folders:
c:\ProgramData\Navigraph\FMSClient and c:\Program Files (x86)\Navigraph\FMS Data Manager.

Download and install latest FMS Data Manager .

Please let us know how you get on.


Thanks for your reply.

I have checked I am using email address and password and have uninstalled it (including making sure all the left over bits are removed) and re-installed and I still get the same error.

If it helps I am running version


As a test and to get you going try Navdata Manual Installations for your addon(s).


Thanks I have already done that, but would like to get the downloader to work to make life easier when I next need to update.

Check you are entering the same email for which you have a subscription, in case you have more than one email registered?

Also check you have the same email and password which permits you to log into other Navigraph services.

If you prefer not to identify your emails, please send via PM.


I use a password manager so can’t see where there would be an issue with the wrong details getting sent, but have just tried copying the info from my password manager manually and I get the same error.

However if I goto Navagraph.com and copy the info from my password manager manually it works fine, I have also checked in my account details to check it is an active subscription, I also double checked to make sure i’m uasing the same email/password.

This is very strange as Navigraph NavData Centre ologged in first time without any issues.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.