Avitab link

when I try to link to navigraph i enter login info enter password opens browser and never closes browser window. (go to navigraph login it comes back with already loged on)

When i try to link avitab to navigraph i connect to the browser and enter password and browser screen goes to blue and never connects to my account

Hello! Welcome back!

It shouldn’t (and can’t) close the browser window for you - you have to do that yourself.
Is the Avitab not successfully signed in when you switch back to the simulator?

Kind Regards,

When I close the browser window and switch back to avitab i am still not linked.

Which browser are you using?

Here are the steps that I take when signing in to Avitab:

  1. Press Link Navigraph Account and then Open Browser

  2. In the opened browser tab, sign in to your Navigraph Account:

  3. Allow AviTab to access the required information using your account:

  4. Once you press allow, you should be presented with this tab confirming successful sign in:


If I understand you correctly, your browser goes blank during one of these steps. Which one? Can you send me a screenshot?

Kind Regards,

the browser screen goes blue, I never get the request permissions screen to allow me to respond “yes, Allow”.

Alright! Please take a look at these questions:

Kind Regards,

well I tried to link to navigraph and for the first time in 5 days it worked!. Hope it continues to work. Thank you for your assistance in this issue!


I am happy to hear it! I hope so too. Enjoy!

Kind Regards,