Issues signing into Charts

Is this issue still being investigated? I’m using version on macOS and still experience this.


I thought this was fixed with V 7.3.8. Please provide details of the problems experienced, included which browser.


I experience the same problem. Below I have described it in more detail:

I have a yearly subscription (since this month) and I also work with Navigraph Charts 7.3.8. I have an iMac (2017) with OS 11.2.3 and Safari as a default browser.

Charts will unexpectedly turn blue on me every two or three days (after working normally), and tell me to sign in. When I click the “Sign In” box, my browser (Safari) opens and asks me for my credentials, which I duly supply of course. I also check the box “remember me” (I like to be remembered).

After that, the trouble begins. Safari tells me I’m signed in and asks me if I wish to be redirected to my desktop application and I click Yes. Safari then answers that I am signed out and asks me if I wish to open Charts. Again. I say yes, upon which I am switched to the blue screen of Charts, still with the Sign In-Box prominently visible. By the way, if I tell Safari NOT to redirect me it just stays on the same page (You are signed in) and nothing happens to the desktop application, not even when I close and reopen it. I then close Safari altogether and reopen Nav Charts and … the miracle happens. I see the charts, I can fly! …. for two days or so, until this circus starts all over again.

This sign-in protocol does not do its job properly, nor does it make sense to have two independent pieces of software (charts and a browser) cooperate on one simple task: checking whether your subscription is still valid.

Please help me solve this issue, as it might spark some sadness shortly.


Paul Overtoom

By the way, since this morning the same mishap occurs with SimLink. Same sad story.

1 Like

This describes my experience perfectly. I’m on a late 2019 MacBook Pro using Safari and Charts build

Hello everyone!

I have split the thread because the issues that you are experiencing might look like the same issue as the previous thread, but it is indeed not as that issue has been fixed.

We are currently upgrading the whole authentication flow in order to make it more stable, and this task is highly prioritized. While we can’t be entirely sure exactly what is causing the issues you are experiencing, we can be quite sure that what we have in store will mitigate them.

Thank you for your patience!

Until then, please do the following:

  • Make sure that you do not have multiple tabs of Navigraph Charts open.
  • If you have issues with the app while running macOS Big Sur, please try reinstalling the application in an effort to reset its permissions to those required by the latest version.

@Overtoom31, you mention having issues with Simlink as well. When you perform the sign-in process, particularly the part where you should be redirected to Simlink, does the application get focused or does it stay in the background?


I will check that, however, Simlink is such a simple application, that it does not give me the option to logout. As I am currently logged in again, I am just waiting until the app asks me again to login. Or should I reinstall Simlink as well?

No need to reinstall if it works! But if it stops working again, taking note of what was mentioned would be valuable to us.

Do you remember what you did to get it to work again?


I think I remember: after I shut down Charts and Safari, I got charts to open in logged-in mode. Something comparable happened in Simlink. It MIGHT have to do with shutting down Safari only, but I have been unable to test that assumption.

A post was split to a new topic: Can’t Login in to Charts

Sorry for the delay in replying to this. I am running Charts on macOS Big Sur. I’ve reinstalled the app as well. The problem manifests when I leave the app running for several days without using it. When I go to use it my authentication is expired and it opens in Safari. When I login there the browser asks to open Charts. When I allow it to open Charts the cycle continues. I’m redirected once again to

Hello again!

We’re currently at a loss as to how that might happen. However, we have some upcoming changes to the authentication process that could possibly fix this, so stay tuned!

If the problem persists after the update (which is coming in the near future), then we’ll dig deeper and try to find the root cause together.

Kind Regards,

1 Like

3 posts were split to a new topic: Charts Desktop not opening browser when authenticating

Okay, so reading up on this thread again I notice some details that I missed or didn’t fully understand the first time.

@Overtoom31 and @myockey

please confirm this for me - when you clicked the redirect button, you were treated to a page with the information shown in this screenshot? If that is the case, then this has never been seen before and we should definitely investigate this specific issue.


When simlink is running, you can sign out of it by pressing the Simlink icon in the status bar and selecting “Sign out”. You can also sign out through the user interface (which you can open by pressing the “Status” option in the previously mentioned menu) and pressing the “Sign out” button to the right of your username.

I understand the frustration, but normally this process is actually way simpler than any alternative. As long as you’re signed in inside the browser (which you should be after buying a subscription) the sign-in process is only a matter of pressing the sign-in button, pressing the “Grant access” in the browser window that opens, allow the redirect and you’re done.

Obviously, when one step along the way fails it becomes quite confusing and frustrating, and we do want to fix this if possible. Right now, it looks like this only happen.

You’re supposed to stay signed in for exactly one year if you do not sign out manually. This is an issue that we have been able to reproduce, and we have some updates incoming that should mitigate it.

If any of you would be able to verify that the issue still occurs if you have another browser as default (Google Chrome or Firefox for example), that would be much appreciated!

Thank you for your patience with this! It is not an easy one, but given the silence in the thread perhaps a macOS update was able to fix this?

Kind Regards,

Dear Malte,

Thanks for your help!1. Simlink is solved There is a Dutch saying relevant to my problem: "I looked with my nose”: I did not look around well enough to notice Simlink’s presence in the status bar.
2. The login problem seems to be solved. I tried several times and now, after logging in, Safari does redirect me to charts and charts shows me my map (in the login status).
3. I cannot say that Charts has stopped kicking me out every few days, because I have not tried to stay logged in for a longer period. If it does kick me out again, I will let you know.


Paul Overtoom

1 Like

Thank you for the fast reply Paul!

I am glad to hear that you are no longer experiencing this annoying bug. Many thanks to you and Michael for cooperating and providing details, let’s hope that the fixes we did were able to resolve the issue for good.

I will mark this thread as solved, but you are both welcome to open a new thread, should the issue start occurring again.

Kind Regards,

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.