Can't login to navdata center


I installed the latest Navdata version 1.0.12 after deinstalling the old version.
When opening the Navdata center (

and clicking on sign in I get this:

This page isn’t working didn’t send any data.


I tried the tipps by changing default browser, reinstalling, it’s not working.

I would appreciate some help! NavChars is working fine. I have no clue whats causing this.


1 Like

Can confirm this is also happening with me with SimLink, ever since they did server maintenance a week ago. Something broke.

I just installed the Navdata center to use it with the MSFS Steam edition, and I experience the same problem. I can enter my data to login, but then I also get an empty page with the above error. Hopefully this can be solved real soon. I use Google Chrome as web browser. I installed the program with the default settings.

Hi Team,

Any chance you are using NordVPN? If so please see Cannot get connected since yesterday - #4 by Ian.


Disabling Threat Protection in Nord VPN worked. It logs in now. Thanks!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.